Вопрос задан 25.07.2023 в 01:54.
Предмет Информатика.
Спрашивает Баранова Стеша.
90 баллов Напишите программу для определения имеет ли женщина идеальный вес. Значения роста и
фактического веса вводится с клавиатуры.Программа вычисляет идеальный вес женщин по формуле. Ид.вес=Рост в см-100-10%(170-100) Затем спрашивает вычисленный идеальный вес женщины с фактическим,и дает заключение является ли фактический вес человека идеальным или нет. Паскаль.Ответы на вопрос
Отвечает Соловей Влад.
program MassaProg;
uses crt;
var factmassa, heigth: integer;
var massa: real;
begin
writeln('Vvedite rost v santimetrah: ');
readln(heigth);
writeln('Vvedite ves: ');
readln(factmassa);
massa:=heigth-100-0.1*(170-100);
if massa = factmassa
then writeln('Vash ves idealnii') else writeln('Vash ves ne idealnii');
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для написания программы на языке Паскаль, которая определит, является ли фактический вес женщины идеальным или нет, следуйте инструкциям ниже:
pascalprogram IdealWeight; var height, actualWeight, idealWeight: real; begin writeln('Введите ваш рост в см: '); readln(height); writeln('Введите ваш фактический вес: '); readln(actualWeight); { Вычисляем идеальный вес по формуле } idealWeight := height - 100 - ((height - 100) * 0.1); writeln('Идеальный вес для вас: ', idealWeight:0:2); { Сравниваем фактический вес с идеальным и даём заключение } if actualWeight = idealWeight then writeln('Ваш фактический вес является идеальным!') else writeln('Ваш фактический вес не является идеальным.'); readln; end.
Программа вычисляет идеальный вес по формуле и затем сравнивает его с введенным фактическим весом. Затем выводит заключение о том, является ли фактический вес идеальным или нет.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 68
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
