Написать программу(язык c++) , которая получает на ввод от 1 до 9 и которая должна выводит таблицу
умножения на это и на следующее число. Надпись «таблица умножения» разместить по центру! Прошу помогите , отдам 15-20 балловОтветы на вопрос
        #include <iostream>
#include <Windows.h>
using namespace std;
int num;
while(true) {
cin >> num;
cout << num << " x 1 = " << num * 1 << endl;
cout << num << " x 2 = " << num * 2 << endl;
cout << num << " x 3 = " << num * 3 << endl;
cout << num << " x 4 = " << num * 4 << endl;
cout << num << " x 5 = " << num * 5 << endl;
cout << num << " x 6 = " << num * 6 << endl;
cout << num << " x 7 = " << num * 7 << endl;
cout << num << " x 8 = " << num * 8 << endl;
cout << num << " x 9 = " << num * 9 << endl;
}
system("pause");
return 0;
Если что-то неправильно сделал, не суди, давно не программировал и уже особо не помню.
            Конечно, я помогу вам написать программу на языке C++, которая будет выводить таблицу умножения для числа, введенного пользователем, и для следующего числа. Для центрирования надписи "Таблица умножения" мы будем использовать пробелы перед самой надписью.
Ниже приведен полный код программы:
cpp#include <iostream>
#include <iomanip>
int main() {
    int num;
    
    // Получаем число от пользователя и проверяем его допустимый диапазон
    do {
        std::cout << "Введите число от 1 до 9: ";
        std::cin >> num;
    } while (num < 1 || num > 9);
    // Очищаем буфер ввода
    std::cin.ignore();
    // Рассчитываем следующее число
    int nextNum = num + 1;
    if (nextNum > 9) {
        nextNum = 1;
    }
    // Выводим таблицу умножения
    std::cout << std::setw(30) << std::right << "Таблица умножения" << std::endl;
    for (int i = 1; i <= 10; ++i) {
        int result = num * i;
        int nextResult = nextNum * i;
        std::cout << std::setw(10) << std::right << num << " * " << std::setw(2) << std::right << i << " = " << std::setw(3) << std::right << result;
        std::cout << "    " << std::setw(10) << std::right << nextNum << " * " << std::setw(2) << std::right << i << " = " << std::setw(3) << std::right << nextResult << std::endl;
    }
    return 0;
}
Вы можете скопировать этот код в вашу среду разработки и скомпилировать его. После запуска программы она запросит у вас число от 1 до 9, а затем выведет таблицу умножения для этого числа и для следующего числа.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			