Вопрос задан 24.07.2023 в 19:01.
Предмет Информатика.
Спрашивает Кучер Славік.
Pascal ABC/ C клавиатуры вводят два слова. Составить программу, которая проверяет, не начинается ли
второе слово с той же буквы, которой оканчивается первое словоОтветы на вопрос
Отвечает Приказчикова Валерия.
var s1,s2: string;
begin
writeln('Введите 2 слова:');
readln(s1);
readln(s2);
if s1[length(s1)]=s2[1]
then writeln('второе слово начинается с той же буквы, которой оканчивается первое слово')
else writeln('последняя буква первого слова отличается от первой буквы второго слова');
end.

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения этой задачи на Pascal ABC/C нужно выполнить следующие шаги:
- Ввести два слова с клавиатуры.
- Получить последнюю букву первого слова.
- Получить первую букву второго слова.
- Сравнить эти буквы.
- Вывести результат проверки.
Вот как может выглядеть программа на Pascal ABC/C:
pascalprogram CheckFirstLastLetters; var firstWord, secondWord: string; firstLastLetter, secondFirstLetter: char; begin writeln('Введите первое слово: '); readln(firstWord); writeln('Введите второе слово: '); readln(secondWord); // Получаем последнюю букву первого слова firstLastLetter := firstWord[length(firstWord)]; // Получаем первую букву второго слова secondFirstLetter := secondWord[1]; // Сравниваем буквы и выводим результат if firstLastLetter = secondFirstLetter then writeln('Второе слово начинается с той же буквы, которой оканчивается первое слово.') else writeln('Второе слово НЕ начинается с той же буквы, которой оканчивается первое слово.'); readln; end.
Программа позволяет пользователю ввести два слова и затем сообщает, начинается ли второе слово с той же буквы, которой оканчивается первое слово.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
