написать программу в pascal группа из 9 студентов сдала 2 экзамена по 2 предметам. оценки от 2 до
5. составить программу которая будет выводить эти сведения и будет показывать количество студентов имеющих СРЕДНИЙ балл меньше 3 по двум экзаменамОтветы на вопрос
const n=9;
var marks:array[1..n,1..2] of 2..5;
i,k:integer;
begin
writeln('Оценки студентов:');
for i:=1 to n do
begin
marks[i,1]:=random(4)+2;
marks[i,2]:=random(4)+2;
writeln(i,': ',marks[i,1]:3,marks[i,2]:3);
end;
k:=0;
for i:=1 to n do
if (marks[i,1]+marks[i,2])/2<3 then k:=k+1;
writeln('Количество студентов, имеющих средний балл < 3 = ',k);
end.
Пример:
Оценки студентов:
1: 5 4
2: 5 4
3: 4 3
4: 5 5
5: 2 2
6: 2 3
7: 5 5
8: 3 4
9: 2 2
Количество студентов, имеющих средний балл < 3 = 3
Для решения данной задачи в Pascal, можно использовать массивы для хранения оценок студентов и подсчитывать количество студентов средний балл которых меньше 3 по двум экзаменам. Вот пример программы:
pascalprogram StudentsGrades; const NumStudents = 9; NumExams = 2; type ExamGrades = array[1..NumExams] of integer; StudentsData = array[1..NumStudents] of ExamGrades; var students: StudentsData; i, j, totalGrades, countBelowAverage: integer; average: real; // Функция для вычисления среднего балла по двум экзаменам для одного студента function CalculateAverage(grades: ExamGrades): real; var sum: integer; begin sum := 0; for i := 1 to NumExams do sum := sum + grades[i]; CalculateAverage := sum / NumExams; end; begin // Ввод оценок для каждого студента и каждого экзамена for i := 1 to NumStudents do begin writeln('Студент №', i, ':'); for j := 1 to NumExams do begin repeat writeln('Введите оценку за экзамен ', j, ' (от 2 до 5): '); readln(students[i][j]); until (students[i][j] >= 2) and (students[i][j] <= 5); end; end; // Вывод данных о студентах и подсчет количества студентов средний балл которых меньше 3 countBelowAverage := 0; for i := 1 to NumStudents do begin average := CalculateAverage(students[i]); writeln('Студент №', i, ': средний балл - ', average:0:2); if average < 3 then Inc(countBelowAverage); end; writeln('Количество студентов со средним баллом меньше 3: ', countBelowAverage); end.
Программа попросит вас ввести оценки каждого студента за оба экзамена. После ввода данных, она выведет средний балл для каждого студента и общее количество студентов со средним баллом меньше 3 по двум экзаменам.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
