Вопрос задан 24.07.2023 в 10:24.
Предмет Информатика.
Спрашивает Дубровина Ира.
Составить программу, которая считывает число. Если оно неотрицательное, извлекает из него корень, в
противном случает выводит соответсвующее сообщение. ПАСКАЛЬОтветы на вопрос
Отвечает Терелёв Артём.
var number: real;
begin
readln(number);
if number > 0 then
writeln(sqrt(number))
else writeln('Число меньше 0!');
end.
Отвечает Шегера Дмитрий.
Var A:real;
Begin
Write('Введите число: ');ReadLn(A);
if A>=0 then A:=sqrtA
else write(a) ;
Write(A);
End.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для создания программы на Pascal, которая считывает число и выводит корень, если число неотрицательное, или соответствующее сообщение, если число отрицательное, можно использовать следующий код:
pascalprogram SquareRootProgram; var number: real; begin writeln('Введите число:'); readln(number); if number >= 0 then writeln('Корень из числа ', number, ' равен ', sqrt(number)) else writeln('Введено отрицательное число, корень из которого невозможно извлечь.'); end.
В этой программе используется переменная number для хранения считанного числа. Затем производится проверка условия: если число больше или равно нулю, программа выводит корень из этого числа с помощью функции sqrt, иначе выводится сообщение о том, что корень невозможно извлечь.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
