
Помогите написать программу на паскале: Даны 3 числа, если это куб-найти объём, если это
параллелепипед-найти площадь поверхности

Ответы на вопрос

var a,b,c,k: real;
begin
write('Введите 1 число: ');
readln(a);
write('Введите 2 число: ');
readln(b);
write('Введите 3 число: ');
readln(c);
if (a=b) and (b=c) and (a=c) then
begin
k:=a*b*c;
writeln('Объем куба равен ',k);
end else
begin
k:=2*(a*b+b*c+a*c);
writeln('Площадь поверхности параллелипипеда равна ',k);
end;
end.



Конечно, помогу написать программу на Pascal, которая будет определять объем куба или площадь поверхности параллелепипеда. В программе мы будем запрашивать у пользователя ввод трех чисел и затем выполнять необходимые вычисления. Предположим, что первое число - длина, второе - ширина, и третье - высота. Вот код программы:
pascalprogram CubeOrParallelepiped; var a, b, c: real; volume: real; surfaceArea: real; isCube: boolean; begin writeln('Введите три числа (длина, ширина, высота):'); readln(a, b, c); // Проверяем, является ли фигура кубом (все стороны равны) isCube := (a = b) and (a = c); if isCube then begin // Вычисляем объем куба volume := a * a * a; writeln('Фигура - куб'); writeln('Объем куба: ', volume:0:2); end else begin // Вычисляем площадь поверхности параллелепипеда surfaceArea := 2 * (a * b + a * c + b * c); writeln('Фигура - параллелепипед'); writeln('Площадь поверхности параллелепипеда: ', surfaceArea:0:2); end; end.
Пользователю будет предложено ввести три числа, и затем программа определит, является ли это кубом или параллелепипедом, после чего выведет объем куба или площадь поверхности параллелепипеда, соответственно.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili