Вопрос задан 24.07.2023 в 02:23.
Предмет Информатика.
Спрашивает Ткач Вася.
Паскаль срочно/!!!!!!! напишите программу которая заполняет массив из N=8 элементов случайными
числами в диапазоне [0,20] , выводит его на экран, а затем меняет местами пары соеденёных элементов, кроме первого и последнего(2 с 3, 4с 5 и т. д.). Пример: Массив :5 16 2 13 3 14 18 17 Реверс:5 2 16 3 13 18 14 17Ответы на вопрос
Отвечает Vyunnik Pavlo.
var
a: array[1..10] of integer;
i, n: integer;
begin
n := 8;
randomize;
for i := 1 to N do
begin
a[i] := random(21);
Write(a[i]:4);
end;
i := 2;
while i <= N - 2 do
begin
Swap(a[i], a[i + 1]);
i += 2
end;
Writeln;
for i := 1 to N do
Write(a[i]:4)
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на языке Паскаль, которая выполняет указанные действия:
pascalprogram SwapConnectedElements; const N = 8; MinValue = 0; MaxValue = 20; var arr: array[1..N] of Integer; i: Integer; temp: Integer; procedure FillArrayRandomly(); var i: Integer; begin Randomize; for i := 1 to N do arr[i] := Random(MaxValue - MinValue + 1) + MinValue; end; procedure PrintArray(); var i: Integer; begin for i := 1 to N do Write(arr[i], ' '); Writeln; end; begin FillArrayRandomly(); Writeln('Массив:'); PrintArray(); for i := 2 to N - 1 step 2 do begin temp := arr[i]; arr[i] := arr[i + 1]; arr[i + 1] := temp; end; Writeln('Реверс:'); PrintArray(); end.
Программа создает массив из 8 элементов, заполняет его случайными числами в диапазоне [0, 20], выводит его на экран, а затем меняет местами пары соединенных элементов, кроме первого и последнего. Результат выводится на экран в обратном порядке, как указано в примере.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
