C++ даны 5 чисел напишите программу которая выводит их в обратном порядке.В программе подается 5
целых неотрецательных чисел числа не больше чем 100000. программс должна вывести "перевернутую" последовательность чисел не содержущую 0 C++Ответы на вопрос
#include <iostream>
#include <cstdlib>
using namespace std;
int main()
{
int mas[5];
for(int i = 0; i < 5; i++){
cout << "Input element[" << i << "] = "; cin >> mas[i];
while(mas[i] < 0){
cout << "Input element[" << i << "] = "; cin >> mas[i];
}
}
cout << "Show massiv" << endl;
for(int i = 0; i < 5; i++){
cout << mas[i] << " ";
}
cout << "\nReversed massiv without zero(0)" << endl;
for(int i = 4; i >= 0; i--){
if(mas[i] != 0){
cout << mas[i] << " ";
}
}
cout << endl;
system("pause");
return 0;
}
#include <iostream>
#include <string>
using namespace std;
int main()
{
string st;
cin>>st;
for(int i=0;i<n;++i)
{
if(s[i] == '0')
{
st=st.erase(i);
}
cout<<reverse(st)<<endl;
system("pause");
return 0;
}
Для решения этой задачи, можно воспользоваться массивом для хранения 5 чисел и затем вывести их в обратном порядке, исключая нули. Вот пример программы на C++:
cpp#include <iostream>
using namespace std;
int main() {
const int SIZE = 5;
int numbers[SIZE];
int reversedNumbers[SIZE];
int count = 0;
cout << "Введите 5 целых неотрицательных чисел (не больше 100000):" << endl;
// Ввод чисел
for (int i = 0; i < SIZE; ++i) {
cin >> numbers[i];
if (numbers[i] != 0) {
reversedNumbers[count] = numbers[i];
++count;
}
}
// Вывод чисел в обратном порядке
cout << "Числа в обратном порядке без нулей:" << endl;
for (int i = count - 1; i >= 0; --i) {
cout << reversedNumbers[i] << " ";
}
cout << endl;
return 0;
}
Программа запрашивает у пользователя ввод 5 целых чисел, затем сохраняет ненулевые числа в массив reversedNumbers. Затем, она выводит эти числа в обратном порядке. Если вам необходимо включить обработку отрицательных чисел, необходимо удалить ограничение "неотрицательных чисел" из условия задачи и убрать проверку numbers[i] != 0.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
