 
составить программу,определяющую сумму положительных элементов одномерного массива B,состоящего из
14 вещественных значений 0
        0
         0
        0
    Ответы на вопрос
 
        var
B: array [1..14] of Real;
i: Integer;
s: Real;
begin
Randomize;
WriteLn ('Mассив:');
for i := Low (B) to High (B) do begin
B [i] := Random (100) - 50;
Write (B [i]:5:2, ' ');
end;
s := 0;
for i := Low (B) to High (B) do begin
if B [i] > 0 then
s := s + B [i];
end;
WriteLn;
WriteLn ('Сумма положительных элементов массива = ', s:5:2);
end.
 0
                    0
                     0
                    0
                 
            Для определения суммы положительных элементов одномерного массива B, состоящего из 14 вещественных значений, можно написать программу на языке программирования, например, на Python. Вот пример такой программы:
pythondef sum_positive_elements(array):
    sum_positive = 0
    for element in array:
        if element > 0:
            sum_positive += element
    return sum_positive
# Определяем одномерный массив из 14 вещественных значений (можно ввести с клавиатуры или предопределить)
B = [1.5, -2.0, 3.2, 0.8, -4.1, 5.7, 6.4, -7.2, 8.9, 9.1, -10.5, 11.3, 12.0, 13.6]
# Вызываем функцию и передаем ей массив B
result = sum_positive_elements(B)
# Выводим результат
print("Сумма положительных элементов массива B:", result)
В этой программе функция sum_positive_elements принимает одномерный массив array в качестве параметра и итерирует по элементам массива, проверяя каждый элемент на положительность. Если элемент положительный, он добавляется к переменной sum_positive. В результате, функция возвращает сумму положительных элементов. После этого, мы создаем массив B и вызываем функцию sum_positive_elements, передавая ей массив B. Выводим результат на экран.
 0
                    0
                     0
                    0
                Похожие вопросы
 
			 
			Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			