Вопрос задан 23.07.2023 в 12:49. Предмет Информатика. Спрашивает Федів Антон.

Надо написать программу которая запрашивает у пользователя число, если число не равно 123, то

программа выводит его на экран, в противном случае процесс повторяется (Python) Пожалуйста СРОЧНО!!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Бондаренко Настя.

def func():

   while True:

       num = int(input('Введите число: '))

       if num == 123:

           print(num)

           break



func()

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот программа на Python, которая будет выполнять описанное вами действие:

python
while True: number = int(input("Введите число: ")) if number != 123: print("Введенное число:", number) break

Эта программа будет бесконечно запрашивать у пользователя ввод числа. Если введенное число не равно 123, программа выведет его на экран и завершит свою работу. В противном случае, она попросит пользователя ввести число снова.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос