Вопрос задан 23.07.2023 в 11:40.
Предмет Информатика.
Спрашивает Юревич Даниэла.
Написать программу в паскале Массив 3х5 заполнить случайными числами [-10;10]. Заменить числом
555 все числа, у которых сумма индексов чётная.Ответы на вопрос
Отвечает Барышникова Лера.
const g=3;v=5;
var i,j,s,m,mi:integer;
a:array [1..g,1..v] of integer;
begin
for i:=1 to g do
begin
for j:=1 to v do
begin
a[i,j]:=random(21)-10;
write (a[i,j]:5)
end;
writeln
end;
writeln;
for i:=1 to g do
begin
for j:=1 to v do
begin
if (i+j) mod 2=0 then a[i,j]:=555;
write (a[i,j]:5)
end;
writeln
end;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения этой задачи вам потребуется использовать два цикла: один для заполнения массива случайными числами, а другой для замены чисел, у которых сумма индексов чётная, на число 555. Вот пример программы на Pascal:
pascalprogram ReplaceEvenSumIndices; const ROWS = 3; COLS = 5; MIN_VALUE = -10; MAX_VALUE = 10; REPLACE_VALUE = 555; var arr: array[1..ROWS, 1..COLS] of Integer; i, j: Integer; begin // Инициализация генератора случайных чисел Randomize; // Заполнение массива случайными числами for i := 1 to ROWS do begin for j := 1 to COLS do begin arr[i, j] := Random(MAX_VALUE - MIN_VALUE + 1) + MIN_VALUE; end; end; // Вывод исходного массива writeln('Исходный массив:'); for i := 1 to ROWS do begin for j := 1 to COLS do begin write(arr[i, j]:5); end; writeln; end; // Замена чисел, у которых сумма индексов чётная, на REPLACE_VALUE for i := 1 to ROWS do begin for j := 1 to COLS do begin if ((i + j) mod 2 = 0) then begin arr[i, j] := REPLACE_VALUE; end; end; end; // Вывод изменённого массива writeln('Массив после замены:'); for i := 1 to ROWS do begin for j := 1 to COLS do begin write(arr[i, j]:5); end; writeln; end; end.
Программа создаст массив размером 3x5, заполнит его случайными числами от -10 до 10, а затем заменит числа, у которых сумма индексов чётная, на число 555. Результаты заполнения и замены будут выведены на экран.
Похожие вопросы
Информатика 78
Информатика 94
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
