Вопрос задан 23.07.2023 в 11:14.
Предмет Информатика.
Спрашивает Кот Николай.
Программа в паскале Массив 3х5 заполнить случайными числами [-10;10]. Заменить числом 555 все
числа, у которых сумма индексов чётная.Ответы на вопрос
Отвечает Бутенко Наталья.
const g=3;v=5;
var i,j,s,m,mi:integer;
a:array [1..g,1..v] of integer;
begin
for i:=1 to g do
begin
for j:=1 to v do
begin
a[i,j]:=random(21)-10;
write (a[i,j]:5)
end;
writeln
end;
writeln;
for i:=1 to g do
begin
for j:=1 to v do
begin
if (i+j) mod 2=0 then a[i,j]:=555;
write (a[i,j]:5)
end;
writeln
end
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для того чтобы написать программу на языке Pascal, которая создаст массив 3x5 и заменит числа, у которых сумма индексов четная, на число 555, следуйте приведенному ниже коду:
pascalprogram ReplaceEvenSumIndices; const ROWS = 3; COLS = 5; var arr: array[1..ROWS, 1..COLS] of integer; i, j: integer; // Функция для генерации случайных чисел в диапазоне [-10;10] function RandomNumber: integer; begin Randomize; Result := Random(21) - 10; end; begin // Заполнение массива случайными числами for i := 1 to ROWS do for j := 1 to COLS do arr[i, j] := RandomNumber; // Вывод исходного массива writeln('Исходный массив:'); for i := 1 to ROWS do begin for j := 1 to COLS do write(arr[i, j]:5); writeln; end; // Замена чисел с четной суммой индексов на 555 for i := 1 to ROWS do for j := 1 to COLS do if (i + j) mod 2 = 0 then arr[i, j] := 555; // Вывод измененного массива writeln('Массив после замены:'); for i := 1 to ROWS do begin for j := 1 to COLS do write(arr[i, j]:5); writeln; end; end.
В этом коде программа сначала заполнит массив случайными числами от -10 до 10, а затем заменит числа, у которых сумма индексов является четной, на число 555. Результат будет выведен на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 25
Информатика 33
Информатика 15
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
