Вопрос задан 23.07.2023 в 11:01.
Предмет Информатика.
Спрашивает Стойка Вікторія.
Составить программу на Паскале: Заполнить массив ВМ случайными числами из диапазона от 1 до 150.
Размерность массива 20.Распечатать массив на экране в строку. Найти сумму всех нечётных чисел массива. Результат вывести на экран в отдельной строке.Ответы на вопрос
Отвечает Шихунов Тимур.
- program n_1;
- const
- n = 20;
- var
- a: array [1..n] of integer;
- i, sum: integer;
- begin
- sum := 0;
- for i := 1 to n do
- begin
- a[i] := random(150) + 1;
- write('a[', i, '] = ', a[i], '; ');
- if odd(a[i]) then inc(sum, a[i]);
- end;
- writeln ();
- write('sum = ', sum);
- end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для составления программы на Паскале, удовлетворяющей вашему запросу, вам понадобится среда программирования, поддерживающая язык Паскаль (например, Free Pascal). Ниже приведена программа, которая выполняет указанные вами шаги:
pascalprogram SumOfOddNumbers; const ARRAY_SIZE = 20; var B: array[1..ARRAY_SIZE] of Integer; i, sum: Integer; begin Randomize; // Инициализация генератора случайных чисел // Заполнение массива ВМ случайными числами из диапазона от 1 до 150 for i := 1 to ARRAY_SIZE do B[i] := Random(150) + 1; // Распечатываем массив на экране в строку Write('Массив B: '); for i := 1 to ARRAY_SIZE do Write(B[i], ' '); // Найдем сумму всех нечетных чисел массива sum := 0; for i := 1 to ARRAY_SIZE do begin if B[i] mod 2 <> 0 then sum := sum + B[i]; end; // Выведем результат на экран Writeln; Writeln('Сумма всех нечетных чисел в массиве: ', sum); end.
Программа объявляет массив B размерности 20, заполняет его случайными числами от 1 до 150, печатает массив на экране, затем находит сумму всех нечетных чисел в массиве и выводит результат на экран в отдельной строке.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 437
Информатика 11
Информатика 10
Информатика 44
Информатика 23
Информатика 43
Информатика 63
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
