Вопрос задан 23.07.2023 в 03:38. Предмет Информатика. Спрашивает Ким Карина.

Помогите решить. Написать программу ,кот.посчитает ,сколько из 5 введенных чисел было чет. и

нечет. ПРОТОКОЛ: Введите 5 чисел 1 2 3 4 5 Четных 3 Нечетных 2 ОБЯЗАТЕЛЬНО БЕЗ ПАСКАЛЯ!
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Королевский Диас.

count1 = 0

count2 = 0

for i in range(0, 5):

   n = int(input())

   if n % 2 == 0:

       count1 += 1

   else:

       count2 += 1

print(count1, count2)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи на подсчет четных и нечетных чисел из 5 введенных пользователем чисел можно воспользоваться практически любым языком программирования. Ниже приведен пример решения на языке Python:

python
even_count = 0 odd_count = 0 try: # Вводим 5 чисел, разделенных пробелами numbers = input("Введите 5 чисел, разделенных пробелами: ") # Разбиваем строку на числа и конвертируем их в целочисленные значения numbers_list = [int(num) for num in numbers.split()] # Проверяем каждое число и увеличиваем соответствующий счетчик for num in numbers_list: if num % 2 == 0: even_count += 1 else: odd_count += 1 # Выводим результат print(f"Четных: {even_count}, Нечетных: {odd_count}") except ValueError: print("Ошибка ввода. Пожалуйста, введите 5 чисел, разделенных пробелами.")

Пример использования:

makefile
Введите 5 чисел, разделенных пробелами: 1 2 3 4 5 Четных: 2, Нечетных: 3

Код позволяет обрабатывать ошибки ввода, например, если пользователь введет неправильное количество чисел или использовать числа в неправильном формате.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос