Задача по pascal. По n≥2 вычислить сумму 1×2+2×3+...+(n-1)×n. Ответ вывести в виде вычисленного
выражения и его значения в точности, как показано в примере. То есть, должно выводиться выражение и ответ.Ответы на вопрос
var
n, r : integer;
begin
while n < 2 do begin
write('введите n = ');
readln(n);
if n < 2 then writeln('n должно быть больше либо равно 2');
end;
for var i :=2 to n do begin
r += (i-1)*i;
write(IntToStr(i-1)+'*'+i.ToString);
if i < n then write('+');
end;
writeln('='+r.ToString);
end.
протестированно в PascalABC.Net
var n,s: integer;
begin
write ('n = ');
readln (n);
for var i :=1 to n-1 do
begin
s:=s+i*(i+1);
write(i,'*',i+1);
if i <> n-1 then write(' + ')
end;
writeln(' = ',s);
end.
Для решения данной задачи на языке Pascal, нужно написать программу, которая будет вычислять указанную сумму и выводить выражение и её значение. Вот код программы:
pascalprogram SumCalculation; var n, sum: Integer; begin writeln('Введите значение n (n >= 2): '); readln(n); if n < 2 then begin writeln('Значение n должно быть больше или равно 2.'); exit; // Выход из программы, если условие не выполнено end; // Вычисление суммы sum := 0; for var i := 1 to n - 1 do sum := sum + i * (i + 1); // Вывод выражения и значения суммы writeln('Выражение: 1*2 + 2*3 + ... + (', n-1, ')*', n); writeln('Ответ: ', sum); end.
Пример работы программы:
makefileВведите значение n (n >= 2):
5
Выражение: 1*2 + 2*3 + 3*4 + 4*5
Ответ: 25
Обратите внимание, что программа проверяет, что значение n является целым числом, большим или равным 2. Если введено некорректное значение, программа выдаст сообщение об ошибке и завершится.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
