:Написать программу на Паскале В переменной Х – Ваша оценка. Вывести, что это за оценка Если «2»
- очень плохо, если «3» - удовл. , если «4» - хорошо, если «5» - отл. 7 классОтветы на вопрос
Program n_1;
var x:integer;
begin
read(x);
case x of
1,2 : writeln('Очень плохо');
3: writeln('Удовлетворительно');
4: writeln('Хорошо');
5: writeln('Отлично');
else writeln('Ошибка');
end
end.
var x:byte;
BEGIN
readln(x);
case x of
2:writeln('Очень плохо.');
3:writeln('Удовлетворительно.');
4:writeln('Хорошо.');
5:writeln('Отлично.');
end;
end.
Для написания программы на Паскале, которая будет определять, какая оценка соответствует заданной переменной X, следуйте приведенному ниже коду:
pascalprogram Оценки; var X: Integer; begin { Вводим оценку в переменную X } Write('Введите вашу оценку (2, 3, 4 или 5): '); Readln(X); { Проверяем значение переменной X и выводим соответствующее сообщение } case X of 2: Writeln('Очень плохо'); 3: Writeln('Удовлетворительно'); 4: Writeln('Хорошо'); 5: Writeln('Отлично'); else Writeln('Введена некорректная оценка. Пожалуйста, введите 2, 3, 4 или 5.'); end; end.
При запуске программы пользователь должен будет ввести свою оценку, а затем программа определит, какой категории соответствует данная оценка. Если пользователь введет оценку, отличную от 2, 3, 4 или 5, программа выдаст сообщение об ошибке.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
