Вопрос задан 22.07.2023 в 14:40. Предмет Информатика. Спрашивает Телкова Анна.

PYTHON Известны четвертные оценки ученика по двенадцати предметам. Необходимо определить, окончил

ли он четверть без троек или нет. Формат входных данных Вводится 12 целых чисел mi (1≤mi≤5) — оценки ученика за четверь. Формат выходных данных Выведите «YES», если троек нет, и «NO» в противном случае. Примеры входные данные выходные данные 4 5 4 5 4 5 4 5 4 5 4 5 YES 3 4 3 4 3 4 3 4 4 4 3 4 NO
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Мамедов Омар-Хаям.

def main():

def check(marks):

 for i in marks:

  if i not in range(1,6):

   normal = False

   break

  else:

   normal = True

 return normal

marks = list(map(int, input().split()))

normal = check(marks)

if normal:

 if marks.count(3) >= 1:

  print('NO')

 else:

  print('YES')

else:

 print('input error. Mark can not be higher than 5 or lower than 1')

if __name__ == "__main__":

main()

end = input()




Не советую копировать, сайт нарушает табуляции в коде и по итогу интерпретатор выдаёт ошибку. Лучше попытаться понять и воссоздать самому

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения данной задачи можно написать простой скрипт на языке Python. Вам потребуется считать входные данные (оценки ученика) и проверить, есть ли среди них оценка "3". В зависимости от наличия троек, выведите соответствующий ответ.

Вот пример кода для решения этой задачи:

python
def check_quarter_grades(grades): return "YES" if 3 not in grades else "NO" # Считываем оценки ученика grades = list(map(int, input().split())) # Проверяем и выводим результат result = check_quarter_grades(grades) print(result)

Программа считывает 12 оценок ученика и помещает их в список grades. Затем она вызывает функцию check_quarter_grades, которая проверяет, есть ли тройки среди оценок, и возвращает соответствующий ответ "YES" или "NO". Наконец, программа выводит результат.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос