Вопрос задан 22.07.2023 в 11:48.
Предмет Информатика.
Спрашивает Игорев Игорь.
Помогите написать программу на языке Паскаль для нахождения среднего значения из n введенных целых
чисел от 10 до 100. Можете сразу вставить числаОтветы на вопрос
Отвечает Жибуль Александр.
var n,i,a,s:integer;
begin
write('n=');
readln(n);
s:=0;
writeln('Введите ',n,' целых чисел');
for i:=1 to n do
begin
readln(a);
if a<0 thn s:=s+a;
end;
write('Сумма отрицательных=',s);
end.
Отвечает Иванова Настя.
var
a,b,c,d,e:integer
begin
read(n);
for c:=1 to n
begin
read(a);
b:=a+b
e:=1+e
end;
write(b/e);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Паскаль для нахождения среднего значения из n введенных целых чисел от 10 до 100:
pascalprogram CalculateAverage; var n, i, num, sum: integer; average: real; begin writeln('Введите количество чисел (n): '); readln(n); if n <= 0 then begin writeln('Некорректное значение для n. Пожалуйста, введите положительное число.'); exit; // Выход из программы, если n некорректное. end; sum := 0; writeln('Введите ', n, ' целых чисел от 10 до 100: '); for i := 1 to n do begin readln(num); if (num < 10) or (num > 100) then begin writeln('Некорректное число. Пожалуйста, введите число от 10 до 100.'); exit; // Выход из программы, если число некорректное. end; sum := sum + num; end; average := sum / n; writeln('Среднее значение: ', average:0:2); end.
Вы можете запустить эту программу и ввести количество чисел (n) и сами числа, чтобы получить среднее значение. Программа проверяет, чтобы введенные значения были корректными (n положительное число, числа от 10 до 100), и выводит среднее значение с двумя знаками после запятой.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 37
Информатика 55
Информатика 12
Информатика 266
Информатика 25
Информатика 33
Информатика 16
Информатика 10
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
