30 БАЛЛОВ, ПАСКАЛЬ Решить каждую задачуСоставить программу, печатающую значение true, если
указанное высказывание является истинным, и false в противном случае:Сумма цифр данного трехзначного числа N является четным числом.Квадрат заданного трехзначного числа равен кубу суммы цифр этого числа.Треугольник со сторонами a, b, c является равнобедренным.Ответы на вопрос
Первая
var n,x:integer;
begin
readln(n);
while n <> 0 do begin
x:=x + n mod 10;
n:=n div 10;
end;
if(x mod 2 = 0) then
writeln('true')
else
writeln('false');
end.
Вторая
var x,z,s:integer;
begin
readln(x);
if (x > 99) and (x < 1000) then begin
s:=x;
while s<>0 do begin
z:=z+s mod 10;
s:=s div 10;
end;
if(x*x) = (z*z*z) then
writeln('true')
else
writeln('false');
end
else
writeln('Число должно быть 3-ех значным!');
end.
Третья
Var a,b,c:Real;
Begin
Writeln('Введите a');
Readln(a);
Writeln('Введите b');
Readln(b);
Writeln('Введите c');
Readln(c);
if (a=b) or (a=c) or (b=c) then
writeln ('true')
else
writeln ('false);
end.
Для решения данной задачи на языке программирования Паскаль, нам необходимо написать программу, которая проверит каждое из указанных высказываний и выведет соответствующее значение true или false в зависимости от того, истинное оно или ложное.
Вот программа на Паскале, которая решает задачу:
pascalprogram CheckStatements; function SumOfDigitsIsEven(number: integer): boolean; var sum, digit: integer; begin sum := 0; while number > 0 do begin digit := number mod 10; sum := sum + digit; number := number div 10; end; Result := (sum mod 2) = 0; end; function SquareEqualsCubeOfSum(number: integer): boolean; var sum, digit: integer; begin sum := 0; while number > 0 do begin digit := number mod 10; sum := sum + digit; number := number div 10; end; Result := sqr(sum) = power(sum, 3); end; function IsIsoscelesTriangle(a, b, c: integer): boolean; begin Result := (a = b) or (b = c) or (a = c); end; var N, a, b, c: integer; begin { Проверка первого высказывания } Write('Введите трехзначное число N: '); Readln(N); WriteLn('Первое высказывание (сумма цифр четная): ', SumOfDigitsIsEven(N)); { Проверка второго высказывания } Write('Введите трехзначное число N: '); Readln(N); WriteLn('Второе высказывание (квадрат равен кубу суммы цифр): ', SquareEqualsCubeOfSum(N)); { Проверка третьего высказывания } Write('Введите стороны треугольника (a, b, c): '); Readln(a, b, c); WriteLn('Третье высказывание (треугольник равнобедренный): ', IsIsoscelesTriangle(a, b, c)); end.
Программа печатает значения true или false в зависимости от истинности каждого высказывания. Вы можете вводить трехзначные числа и стороны треугольника для проверки их соответствия условиям высказываний.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
