Вопрос задан 21.07.2023 в 10:25.
Предмет Информатика.
Спрашивает Богатов Яша.
Написать программу в паскале , которая получает n чисел ( n вводится с клавиатуры) и находит сумму
чисел, заканчивающихся цифрой "0" ОЧЕНЬ СРОЧНО!!!!Ответы на вопрос
Отвечает Некрасова Маргарита.
var
i,n,s, k : integer;
begin
s:=0;
readln (n);
for i:= 1 to n do begin
readln (k);
if k mod 10 =0 then s:= s+k;
end;
writeln (s);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на языке Паскаль, которая считывает n чисел и находит их сумму, если они заканчиваются цифрой "0":
pascalprogram SumOfNumbersEndingWithZero; var n, num, sum: integer; i: integer; begin sum := 0; // Вводим количество чисел n write('Введите количество чисел n: '); readln(n); // Считываем n чисел и находим сумму чисел, заканчивающихся на "0" for i := 1 to n do begin write('Введите число ', i, ': '); readln(num); // Если число заканчивается на "0", добавляем его к сумме if num mod 10 = 0 then sum := sum + num; end; writeln('Сумма чисел, заканчивающихся на "0": ', sum); end.
Пожалуйста, скопируйте этот код в свою среду программирования на Паскале и запустите его, чтобы решить вашу задачу. Удачи!
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 37
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
