Составить программу которая вводит массив из 10 элементов и печатает разность между максимальным и
минимальным значением. На Паскале, элементы целого типаОтветы на вопрос
Var i, max, min:Integer;
A:array[1..10]of integer;
Begin
Max:=-1;min:=10;
For i:=1 to 10 do begin
A[i]:=random(10);
Write(' ', a[i]) ;
If a[i]>max then max:=A[i];
If a[i]<min then min:=a[i];
End;
Writeln;
Write(max-min) ;
End.
Для решения данной задачи на языке Pascal, вам потребуется объявить массив из 10 элементов целого типа, ввести значения элементов массива с клавиатуры, найти максимальное и минимальное значения и вычислить разность между ними. Вот программа, которая выполняет указанные действия:
pascalprogram FindMinMaxDifference; const ARRAY_SIZE = 10; var arr: array[1..ARRAY_SIZE] of Integer; i, maxVal, minVal, diff: Integer; begin writeln('Введите ', ARRAY_SIZE, ' элементов массива:'); for i := 1 to ARRAY_SIZE do readln(arr[i]); { Найдем максимальное и минимальное значения } maxVal := arr[1]; minVal := arr[1]; for i := 2 to ARRAY_SIZE do begin if arr[i] > maxVal then maxVal := arr[i]; if arr[i] < minVal then minVal := arr[i]; end; { Вычислим разность } diff := maxVal - minVal; writeln('Максимальное значение: ', maxVal); writeln('Минимальное значение: ', minVal); writeln('Разность между максимальным и минимальным значением: ', diff); end.
Сначала программа запросит у пользователя ввод 10 элементов массива. Затем она найдет максимальное и минимальное значения, а затем вычислит разность между ними и выведет результат на экран.
Обратите внимание, что в данной программе предполагается, что пользователь будет вводить корректные целочисленные значения для каждого элемента массива.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
