 
Вопрос задан 20.07.2023 в 18:01.
Предмет Информатика.
Спрашивает Петухова Полина.
составить программу для задачи: задается список из 10 чисел, требуется подсчитать количество
положительных и отрицательных чисел. 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Чугай Станислав.
                
    program chizla;
var k,x,i,a:integer;
begin
x:=0;
k:=0;
writeln ('Введите числа');
for i:=1 to 10 do
begin
readln(a);
if a<0 then
k:=k+1;
if a>0 then
x:=x+1;
end;
writeln('Положительных ',x,' Отрицательных ',k);
end.
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Для решения этой задачи можно написать программу на языке программирования Python. Вот пример программы:
pythondef count_positive_negative_numbers(numbers_list):
    positive_count = 0
    negative_count = 0
    for num in numbers_list:
        if num > 0:
            positive_count += 1
        elif num < 0:
            negative_count += 1
    return positive_count, negative_count
# Пример списка из 10 чисел
numbers_list = [5, -2, 0, 10, -7, 3, -1, 8, -6, 4]
positive_count, negative_count = count_positive_negative_numbers(numbers_list)
print("Количество положительных чисел:", positive_count)
print("Количество отрицательных чисел:", negative_count)
Вы можете заменить пример списка numbers_list на свой собственный список из 10 чисел, и программа выведет количество положительных и отрицательных чисел в вашем списке.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			