Сделайте на паскаль без while, а с циклом for пж. Напишите программу, которая в
последовательности целых чисел определяет количество нечётных чисел, кратных 3. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности (завершающий 0 не учитывается) и количество нечётных чисел, кратных 3.Ответы на вопрос
Ответ:
Объяснение:
var a,i,kol,s:integer;
begin
writeln('Введите последовательность целых чисел, 0 - все введены');
s:=0;
kol:=0;
for i:=1 to 1000 do
begin
readln(a);
if a<>0 then
begin
kol:=kol+1;
if (a mod 2<>0) and (a mod 3=0) then s:=s+1; end
else break;
end;
writeln('Введенных чисел ',kol);
writeln('Нечетных чисел кратных трем ',s);
readln;
end.
Для написания программы на Pascal с использованием цикла for для определения количества нечётных чисел, кратных 3, в последовательности целых чисел, можно использовать следующий код:
pascalprogram CountOddMultiplesOfThree; const MaxNumbers = 1000; MaxValue = 30000; var sequence: array[1..MaxNumbers] of Integer; lengthSequence, oddMultiplesOfThreeCount, number: Integer; i: Integer; begin lengthSequence := 0; oddMultiplesOfThreeCount := 0; // Ввод последовательности чисел repeat Readln(number); if (number <> 0) and (lengthSequence < MaxNumbers) and (Abs(number) <= MaxValue) then begin Inc(lengthSequence); sequence[lengthSequence] := number; end; until number = 0; // Поиск нечётных чисел, кратных 3 for i := 1 to lengthSequence do begin if (sequence[i] mod 2 <> 0) and (sequence[i] mod 3 = 0) then Inc(oddMultiplesOfThreeCount); end; // Вывод результатов Writeln('Длина последовательности: ', lengthSequence); Writeln('Количество нечётных чисел, кратных 3: ', oddMultiplesOfThreeCount); end.
Программа считывает числа в цикле repeat/until, пока не будет введено число 0 (завершающий символ). Затем, в цикле for, она проверяет каждое число в последовательности на нечётность и кратность 3. Найденные нечётные числа, кратные 3, увеличивают счётчик oddMultiplesOfThreeCount. В конце программа выводит длину последовательности и количество нечётных чисел, кратных 3.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
