Дан массив L(n,n). Найти максимальный среди отрицательных элементов и сумму элементов на главной
диагонали. Написать программу в Pascal,пожалуйстаОтветы на вопрос
        program raf105;
const
n = 4;
var
a: array[1..n,1..n] of integer;
i,j,max,sum: integer;
begin
for i:=1 to n do
begin
for j:=1 to n do
begin
a[i,j]:= random(-9,9); // Заполнение массива
write(a[i,j]:2,' '); // Вывод массива
if a[i,j] < 0 then
if max = 0 then
max:= a[i,j]
else
if max < a[i,j] then
max:= a[i,j];
if i = j then
sum:= sum + a[i,j];
end;
writeln;
end;
writeln('Максимальный среди отрицательных элементов: ',max);
writeln('Сумма элементов главной диагонали: ',sum);
end.
PascalABC
            Конечно, вот пример программы на Pascal для нахождения максимального отрицательного элемента и суммы элементов на главной диагонали в двумерном массиве L(n,n):
pascalprogram MaxNegativeAndDiagonalSum; const MAX_SIZE = 100; type TwoDimensionalArray = array[1..MAX_SIZE, 1..MAX_SIZE] of integer; var L: TwoDimensionalArray; n, i, j: integer; maxNegative, diagonalSum: integer; // Функция для нахождения максимального отрицательного элемента function FindMaxNegative(arr: TwoDimensionalArray; size: integer): integer; var i, j: integer; maxNeg: integer; begin maxNeg := -1; // Предполагаем, что нет отрицательных элементов for i := 1 to size do begin for j := 1 to size do begin if (arr[i, j] < 0) and ((maxNeg = -1) or (arr[i, j] > maxNeg)) then maxNeg := arr[i, j]; end; end; FindMaxNegative := maxNeg; end; begin // Ввод размера массива writeln('Введите размер массива (n): '); readln(n); // Ввод элементов массива writeln('Введите элементы массива L(', n, ', ', n, '): '); for i := 1 to n do begin for j := 1 to n do read(L[i, j]); end; // Нахождение максимального отрицательного элемента maxNegative := FindMaxNegative(L, n); // Нахождение суммы элементов на главной диагонали diagonalSum := 0; for i := 1 to n do diagonalSum := diagonalSum + L[i, i]; // Вывод результатов writeln('Максимальный отрицательный элемент: ', maxNegative); writeln('Сумма элементов на главной диагонали: ', diagonalSum); end.
Программа позволяет ввести двумерный массив размером n x n и затем находит максимальный отрицательный элемент и сумму элементов на главной диагонали. Обратите внимание, что программа предполагает корректный ввод данных, то есть пользователь не должен вводить элементы массива, которые не являются целыми числами.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			
Математика
 - 
			
Литература
 - 
			
Алгебра
 - 
			
Русский язык
 - 
			
Геометрия
 - 
			
Английский язык
 - 
			
Химия
 - 
			
Физика
 - 
			
Биология
 - 
			
Другие предметы
 - 
			
История
 - 
			
Обществознание
 - 
			
Окружающий мир
 - 
			
География
 - 
			
Українська мова
 - 
			
Информатика
 - 
			
Українська література
 - 
			
Қазақ тiлi
 - 
			
Экономика
 - 
			
Музыка
 - 
			
Право
 - 
			
Беларуская мова
 - 
			
Французский язык
 - 
			
Немецкий язык
 - 
			
МХК
 - 
			
ОБЖ
 - 
			
Психология
 - 
			
Физкультура и спорт
 - 
			
Астрономия
 - 
			
Кыргыз тили
 - 
			
Оʻzbek tili
 
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			
			