Вопрос задан 20.07.2023 в 06:25.
Предмет Информатика.
Спрашивает Крюков Андрей.
Написать программу печати квадратов всех натуральных чисел от 1 до n. Паскаль, цикл-for. Пожалуйста
помогите,очень нужно!!!!!Ответы на вопрос
Отвечает Смирнов Евгений.
Ответ:
Объяснение:
var n,i:integer;
begin
write('Введите N ');
readln(n);
for i:=1 to n do
writeln(i,'^2= ',sqr(i));
readln;
end.
Если уж совсем просто, то:
var n,i:integer;
begin
write('Введите N ');
readln(n);
for i:=1 to n do
writeln(i*i);
readln;
end.

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я помогу вам написать программу на языке Паскаль для печати квадратов всех натуральных чисел от 1 до n с использованием цикла for. Вот пример такой программы:
pascalprogram PrintSquares; var n, i, square: Integer; begin Write('Введите значение n: '); ReadLn(n); WriteLn('Квадраты натуральных чисел от 1 до ', n, ':'); for i := 1 to n do begin square := i * i; WriteLn(i, ' * ', i, ' = ', square); end; end.
Эта программа запрашивает у пользователя число n, а затем выводит квадраты всех натуральных чисел от 1 до n. Квадрат каждого числа вычисляется и выводится в цикле for с использованием переменной square.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 74
Информатика 34
Информатика 39
Информатика 19
Информатика 266
Информатика 34
Информатика 29
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
