Задание по программированию на С++ С использованием оператора switch () написать программу,
которая будет выводить на экран: «Введи количество углов», затем считывать введенное с клавиатуры целое число и выводить на экран при соответствующем введенном значении одну из фраз: «Это треугольник», «Это четырехугольник», «Это пятиугольник», «Это многоугольник» или «Нет такого многоугольника»Ответы на вопрос
#include <iostream>
using namespace std;
int main(){
setlocale(LC_ALL, "Russian");
int a;
cout<<"Введи количество углов"<<endl;
cin>>a;
if (a<3) {cout<<"Нет такого многоугольника"; return 0;}
switch(a){
case 3: cout<<"Это треугольник"; break;
case 4: cout<<"Это четырехугольник"; break;
case 5: cout<<"Это пятиугольник"; break;
default: cout<<"Это многоугольник"; break;
}
return 0;
}
Для решения этой задачи вам понадобится использовать оператор switch вместе с функцией cout для вывода сообщений на экран, и функцию cin для чтения значения из ввода пользователя. Ниже представлен полный код программы на языке C++:
cpp#include <iostream>
int main() {
int numSides;
std::cout << "Введи количество углов: ";
std::cin >> numSides;
switch (numSides) {
case 3:
std::cout << "Это треугольник" << std::endl;
break;
case 4:
std::cout << "Это четырехугольник" << std::endl;
break;
case 5:
std::cout << "Это пятиугольник" << std::endl;
break;
default:
if (numSides > 5)
std::cout << "Это многоугольник" << std::endl;
else
std::cout << "Нет такого многоугольника" << std::endl;
break;
}
return 0;
}
Когда вы запустите эту программу, она выведет на экран сообщение "Введи количество углов". После этого она будет ожидать ввода числа от пользователя. После ввода числа программа сравнит его с разными значениями в блоке switch и выведет соответствующее сообщение. Если введенное число больше 5, программа выведет "Это многоугольник". Если число меньше или равно 5, программа выведет "Нет такого многоугольника".
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
