Вопрос задан 20.07.2023 в 01:23.
Предмет Информатика.
Спрашивает Малинович Назар.
Язык паскаль, можно через while Написать программу, в которой осуществляется ввод целых чисел
(ввод осуществляется до тех пор пока не будет введён ноль) и подсчёт суммы введённых положительных чисел. Используйте оператор repeatОтветы на вопрос
Отвечает Коробицын Славик.
Ответ:
Объяснение:
Pascal
var a,i,s,n:integer;
begin
s:=0;
n:=0;
repeat
readln(a);
if a>0 then begin
n:=n+1;
s:=s+a;
end;
until a = 0;
writeln('Сумма ',s:5,' Среднее арифметическое ',s/n);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, можно написать программу на языке Паскаль с использованием оператора repeat для подсчета суммы введенных положительных чисел. Вот пример кода:
pascalprogram SumPositiveNumbers; var number, sum: integer; begin sum := 0; writeln('Введите целые числа. Вводите числа до тех пор, пока не будет введен ноль.'); repeat write('Введите число: '); readln(number); if number > 0 then sum := sum + number; until number = 0; writeln('Сумма положительных чисел: ', sum); end.
Эта программа будет запрашивать ввод целых чисел до тех пор, пока не будет введен ноль. Все положительные числа будут добавлены к переменной sum, которая в конце программы выведет сумму положительных чисел на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
