
написать программу для подсчета чисел от k до 34+n которая будет работать только если введенное
число K больше 5 но меньше N. Используйте для этого цикл For и цикл do...while

Ответы на вопрос

program raf105;
var k,n,x,i:integer;
begin
write('K = ');
readln(k);
write('N = ');
readln(n);
if (k > 5) and (k < n)
then
begin
for i:=k to 34+n do
x += 1;
writeln('Вывод: ',x);
end
else
writeln('Условия k > 5, k < n не соблюдены');
end.
Язык PascalABC



Для написания программы, которая будет подсчитывать числа от k до 34 + n при условии, что k больше 5 и меньше n, используем цикл for
и do...while
. Ниже приведен пример программы на языке C++:
cpp#include <iostream>
int main() {
int k, n;
// Ввод чисел k и n с проверкой условий
do {
std::cout << "Введите число K (больше 5): ";
std::cin >> k;
} while (k <= 5);
do {
std::cout << "Введите число N (больше K): ";
std::cin >> n;
} while (n <= k);
// Подсчет чисел от k до 34 + n с использованием цикла for
std::cout << "Числа от " << k << " до " << 34 + n << ":\n";
for (int i = k; i <= 34 + n; ++i) {
std::cout << i << " ";
}
std::cout << std::endl;
return 0;
}
При запуске программы пользователь будет приглашен ввести значение k, которое должно быть больше 5. Если введено значение меньше или равное 5, программа будет просить ввести значение k снова. Затем программа запросит ввести значение n, которое должно быть больше k. Если введено значение меньше или равное k, программа будет просить ввести значение n снова. После успешного ввода верных значений k и n, программа подсчитает и выведет числа от k до 34 + n.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili