Вопрос задан 19.07.2023 в 21:34.
Предмет Информатика.
Спрашивает Веселов Женя.
Срочно! Напишите программу в паскале с оператором repeat Дано целое число N (>0) используя
операции деления нацело и взятия остатка от деления, найти количество и сумму его цифр (N=63)Ответы на вопрос
Отвечает Тимергазин Эмиль.
Ответ:
var n,l,s,k:int64;
begin
read(n);
repeat
k:=n mod 10;
s:=s+k;
l:=l+1;
n:=n div 10;
until n=0;
write(l,' ',s);
end.
Объяснение:
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Хорошо, вот программа на Pascal, которая находит количество и сумму цифр заданного целого числа N:
pascalprogram CountAndSumDigits; var N, num, digit, sum, count: Integer; begin { Вводим число N } writeln('Введите целое число N (>0): '); readln(N); { Инициализируем переменные sum и count } sum := 0; count := 0; { Вычисляем сумму и количество цифр числа N } num := N; { Сохраняем исходное значение N } repeat digit := num mod 10; { Получаем последнюю цифру числа } sum := sum + digit; { Добавляем цифру к сумме } count := count + 1; { Увеличиваем счетчик цифр } num := num div 10; { Убираем последнюю цифру из числа } until num = 0; { Повторяем, пока число не станет равным 0 } { Выводим результаты } writeln('Количество цифр числа ', N, ' = ', count); writeln('Сумма цифр числа ', N, ' = ', sum); end.
Эта программа принимает число N от пользователя, а затем с использованием операций деления нацело и взятия остатка от деления, находит количество и сумму его цифр. Введите число N, и программа выведет результаты.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 143
Информатика 285
Информатика 32
Информатика 56
Информатика 381
Информатика 178
Информатика 2232
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
