Написать программу определения минимального из введённых N чисел. Паскаль, цикл-for. Помогите
пожалуйста!!!Ответы на вопрос
program Comparison;
var
N, i, num, min:integer;
begin
write('Введите количество чисел: ');
readln(N);
write('Введите число: ');
readln(num);
min:=num;
for i:= 1 to (N-1) do
begin
readln(num);
if (num<min) then min:=num;
end;
writeln('Минимальное число в последовательности: ',min);
end.
Конечно! Вот пример программы на языке Pascal, которая позволяет определить минимальное из введенных N чисел с использованием цикла for:
pascalprogram MinNumber; var N, i, number, min: Integer; begin Write('Введите количество чисел (N): '); ReadLn(N); Write('Введите число 1: '); ReadLn(min); for i := 2 to N do begin Write('Введите число ', i, ': '); ReadLn(number); if number < min then min := number; end; WriteLn('Минимальное число: ', min); ReadLn; end.
В этой программе сначала пользователь вводит количество чисел N. Затем программа запрашивает первое число и сохраняет его в переменной min. Затем с помощью цикла for программа запрашивает остальные N-1 чисел и сравнивает их с текущим минимальным числом. Если очередное число меньше текущего минимального, то оно становится новым минимальным числом. В конце программа выводит найденное минимальное число.
Надеюсь, это поможет! Если у вас есть еще вопросы, не стесняйтесь задавать.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
