Дан двумерный массив целых чисел. Написать программу, которая:определяет номер последнего столбца,
у которого нечетных элементов больше чем четных.(паскаль)Ответы на вопрос
program raf105;
const
n = 5;
var
a: array[1..n,1..n] of integer;
i,j,num,n1,n2: integer;
begin
writeln('Вводите числа столбцов матрицы по очереди');
for i:=1 to n do
begin
writeln('Столбец ',i);
for j:=1 to n do
readln(a[i,j]);
end;
for i:=1 to n do
begin
n1:= 0;
n2:= 0;
for j:=1 to n do
begin
if (a[i,j] mod 2 <> 0) and (a[i,j] <> 0)
then n1:= n1+1;
end;
for j:=1 to n do
begin
if (a[i,j] mod 2 = 0) and (a[i,j] <> 0)
then n2:= n2+1;
end;
if n1 > n2
then num:= i;
end;
writeln('Вывод: ',num);
end.
PascalABC 3.4.2
Для решения данной задачи на языке Паскаль, можно использовать следующий код:
pascalprogram LastColumnWithMoreOdds; const MAX_ROWS = 100; // Максимальное количество строк в массиве MAX_COLS = 100; // Максимальное количество столбцов в массиве; type TwoDIntArray = array[1..MAX_ROWS, 1..MAX_COLS] of Integer; var arr: TwoDIntArray; rows, cols: Integer; lastColumn: Integer; // Функция для подсчета количества нечетных элементов в столбце function CountOddsInColumn(column: Integer): Integer; var row: Integer; begin Result := 0; for row := 1 to rows do begin if arr[row, column] mod 2 <> 0 then Inc(Result); end; end; begin // Ввод размеров массива Write('Введите количество строк: '); Readln(rows); Write('Введите количество столбцов: '); Readln(cols); // Ввод элементов массива Writeln('Введите элементы массива:'); for row := 1 to rows do begin for lastColumn := 1 to cols do begin Read(arr[row, lastColumn]); end; end; // Поиск последнего столбца с большим количеством нечетных элементов lastColumn := -1; // Изначально считаем, что такого столбца нет for col := 1 to cols do begin if CountOddsInColumn(col) > cols div 2 then lastColumn := col; end; // Вывод результата if lastColumn <> -1 then Writeln('Номер последнего столбца с большим количеством нечетных элементов: ', lastColumn) else Writeln('Столбцов с большим количеством нечетных элементов не найдено.'); end.
Этот код позволит пользователю ввести размеры двумерного массива и его элементы, а затем найдет номер последнего столбца, в котором количество нечетных элементов больше четных.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
