
Необходимо сделать программу на паскале. Есть "капитал" (необходимо вводить самому с клавы), этот
капиал каждый рабочий день (пн, вт, ср, чт, пт) увеличивается на n процентов (число вводится с клаввиатуры) при условии, что после каждого дня капитал увеличивается на те самые n процентов. Сколько денег будет на капитале через n дней (тоже вводится с клавы). Пример: было 600₽, каждый день этот капиал увеличивается на 10%,в итоге первый день 660₽, второй день 726₽, третий день 798,6₽, четвёртый 878,46₽. Число в итоге должно быть округлено до тысячных. 70 баллов даю.

Ответы на вопрос

program raf105;
var
capital,n: real;
i,d,weekday: integer;
begin
write('Введите капитал: ');
readln(capital);
write('Введите рост капитала(%): ');
readln(n);
write('Введите количество дней: ');
readln(d);
for i:=1 to d do
begin
if weekday = 7
then weekday:= 0;
weekday+=1;
if weekday <= 5
then capital+= capital/100*n;
end;
writeln('Через ',d,' дн. на капитале будет ',capital:0:2,' руб.');
end.
Язык PascalABC



Хорошо, я помогу вам написать программу на языке Паскаль, которая рассчитает капитал через n дней с заданным процентным приростом. Для округления числа до тысячных, мы будем использовать функцию Round
.
Вот программа:
pascalprogram CalculateCapital; var capital: real; // Исходный капитал growthRate: real; // Процентный прирост капитала numDays: integer; // Количество дней function CalculateCapitalAfterNDays(capital, growthRate: real; numDays: integer): real; var i: integer; begin for i := 1 to numDays do capital := capital + capital * (growthRate / 100); CalculateCapitalAfterNDays := capital; end; begin // Ввод данных с клавиатуры writeln('Введите исходный капитал: '); readln(capital); writeln('Введите процентный прирост капитала (например, 10): '); readln(growthRate); writeln('Введите количество дней: '); readln(numDays); // Рассчитываем капитал через n дней capital := CalculateCapitalAfterNDays(capital, growthRate, numDays); // Выводим результат с округлением до тысячных writeln('Капитал через ', numDays, ' дней составит: ', Round(capital * 1000) / 1000:0:2, '₽'); end.
При запуске программы вы сможете ввести исходный капитал, процентный прирост и количество дней. Программа рассчитает капитал через указанное количество дней с учетом процентного прироста и выведет результат, округленный до тысячных.


Похожие вопросы
Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili