Вопрос задан 19.07.2023 в 06:39. Предмет Информатика. Спрашивает Стебакова Олеся.

Помогите с основами JAVA! Напишите программу где я ввожу логин и пароль. И если они совпадают, то

мы выводим Authentication completed, иначе Invalid login or password. (Логин должен быть user, пароль - qwerty) Сравнение строк вы делаете с помощью метода equals().
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Мирная Даша.

Ответ:

import java.util.Scanner;

public class Authenticator {

public static void main(String[] args) {

 String login;

 String password;

 Scanner scan = new Scanner(System.in);

 

 System.out.println("login:");

 login = scan.next();

 System.out.println("password:");

 password = scan.next();

 

 if(login.equals("user") && password.equals("qwerty")){

  System.out.println("Authentication completed");

 }else{

  System.out.println("Invalid login or password");

 }

 

 scan.close();

 

}

}

Объяснение:

Краткий алгоритм этой программы:

  1. Импортируем класс Scanner(для ввода текста);
  2. В методе main создаем две переменные типа String и одну типа Scanner;
  3. Вводим значения при помощи Scanner'а;
  4. Если логин и пароль верны,то выводим Authentication completed. Иначе выводим Invalid login or password;
  5. Закрываем Scanner;
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я помогу вам написать программу на Java для аутентификации с использованием метода equals() для сравнения строк. Вот пример кода:

java
import java.util.Scanner; public class AuthenticationProgram { public static void main(String[] args) { // Определение логина и пароля String correctLogin = "user"; String correctPassword = "qwerty"; // Получение ввода пользователя Scanner scanner = new Scanner(System.in); System.out.print("Введите логин: "); String loginInput = scanner.nextLine(); System.out.print("Введите пароль: "); String passwordInput = scanner.nextLine(); // Проверка на совпадение логина и пароля if (correctLogin.equals(loginInput) && correctPassword.equals(passwordInput)) { System.out.println("Authentication completed"); } else { System.out.println("Invalid login or password"); } // Закрытие Scanner scanner.close(); } }

Как только программа запустится, она запросит ввод логина и пароля. Если введенные данные совпадают с правильными, то будет выведено "Authentication completed". В противном случае, программа выведет "Invalid login or password".

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос