
Задача по Java! Вводим число a и b. Программа должна вывести таблицу степени an, где n это числа
которые идут от 0 до b.

Ответы на вопрос

Ответ:
import java.util.Scanner;
public class Power {
public static void main(String[] args) {
int a,b,n,i,result;
Scanner scan = new Scanner(System.in);
System.out.println("a:");
a = scan.nextInt();
System.out.println("b:");
b = scan.nextInt();
for(n=0;n<=b;n++){
result=1;
for(i=0;i<n;i++){
result=result*a;
}
System.out.println(a+"^"+n+"="+result);
}
scan.close();
}
}
Объяснение:
Программа вычисляет значения a в степени n,где n идет от 0 до b включительно.
Краткий алгоритм программы:
- Импортируем Scanner(для ввода);
- В методе main создаем 5 переменных типа int и один объект класса Scanner;
- Вводим числа a,b;
- Запускаем "двойной" цикл;
- В цикле вычисляем a в степени n и выводим результат;
- Закрываем Scanner;



Хорошо, для решения этой задачи вам потребуется написать программу на Java, которая будет выводить таблицу степеней числа a
, где n
изменяется от 0 до b
. Ниже приведен пример кода для выполнения этой задачи:
javaimport java.util.Scanner;
public class PowerTable {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
System.out.print("Введите число a: ");
int a = scanner.nextInt();
System.out.print("Введите число b: ");
int b = scanner.nextInt();
System.out.println("Таблица степеней числа " + a + ":");
for (int n = 0; n <= b; n++) {
long result = power(a, n);
System.out.println(a + "^" + n + " = " + result);
}
}
private static long power(int base, int exponent) {
if (exponent == 0) {
return 1;
}
long result = 1;
for (int i = 0; i < exponent; i++) {
result *= base;
}
return result;
}
}
Программа запрашивает у пользователя числа a
и b
, а затем выводит таблицу степеней числа a
в диапазоне от 0 до b
. Мы используем метод power
, чтобы вычислить степени числа a
. Обратите внимание, что в данной реализации я использую тип long
, чтобы обеспечить поддержку больших чисел, в случае если степени станут очень большими.


Похожие вопросы








Топ вопросов за вчера в категории Информатика








Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili