Вопрос задан 18.07.2023 в 00:15.
Предмет Информатика.
Спрашивает Крекотень Кристина.
Напишите программу которая находит и выводит на экран 4 максимальных элемента последовательности
числа которой различны. Язык ПаскальОтветы на вопрос
Отвечает Бойцова Вероника.
type z=array of integer;
var a: z;
i,j,k: integer;
begin
setlength(a,1);
readln(a[0]);
i:=1;
while(a[i-1]<>0) do
begin
setlength(a,i+1);
readln(a[i]);
i:=i+1;
end;
setlength(a,length(a)-1);
for i:=0 to length(a) do
for j:=0 to length(a)-2 do
if (a[j] < a[j+1]) then
begin
k:=a[j];
a[j]:= a[j+1];
a[j+1]:=k;
end;
write(a[0],'; ',a[1],'; ',a[2],'; ',a[3]);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно! Вот пример программы на языке Паскаль, которая находит и выводит на экран 4 максимальных элемента последовательности чисел с уникальными значениями:
pascalprogram MaxUniqueElements; const MAX_ELEMENTS = 4; var sequence: array[1..100] of Integer; // Предполагаем, что последовательность содержит не более 100 элементов numElements, i, j, temp: Integer; uniqueElements: array[1..MAX_ELEMENTS] of Integer; begin // Вводим количество элементов последовательности Write('Введите количество элементов последовательности: '); ReadLn(numElements); // Вводим последовательность чисел WriteLn('Введите элементы последовательности:'); for i := 1 to numElements do ReadLn(sequence[i]); // Находим уникальные элементы j := 0; for i := 1 to numElements do begin if (j = MAX_ELEMENTS) then Break; // Проверяем, является ли текущий элемент уникальным if (i = 1) or (sequence[i] <> sequence[i-1]) then begin Inc(j); uniqueElements[j] := sequence[i]; end; end; // Сортируем уникальные элементы по убыванию for i := 1 to MAX_ELEMENTS - 1 do begin for j := 1 to MAX_ELEMENTS - i do begin if uniqueElements[j] < uniqueElements[j+1] then begin temp := uniqueElements[j]; uniqueElements[j] := uniqueElements[j+1]; uniqueElements[j+1] := temp; end; end; end; // Выводим 4 максимальных уникальных элемента WriteLn('4 максимальных уникальных элемента последовательности:'); for i := 1 to MAX_ELEMENTS do WriteLn(uniqueElements[i]); ReadLn; end.
Программа запрашивает у пользователя количество элементов в последовательности, а затем последовательно запрашивает сами элементы. Она находит 4 максимальных уникальных элемента, сортирует их по убыванию и выводит на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 437
Информатика 11
Информатика 10
Информатика 44
Информатика 23
Информатика 43
Информатика 63
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
