
В ПАСКАЛЕ 1. Тор и ЛокиОграничение времени 1 секундаОграничение памяти 64MbВвод стандартный ввод
или input.txtВывод стандартный вывод или output.txtЖители Асгарда, прежде всего, ценили физическую силу, упорство и храбрость в сражениях. Поэтому даже в школе математику они изучали на примере своих любимых (и не очень) героев. Однажды учитель задал им следующую задачу: «Сила Тора больше на N силы Локи, а сила Локи меньше силы Тора в M раз.Определите, какая сила у Тора и Локи». Самому талантливому ученику предложили решить эту задачу с помощью программного кода.Формат вводаНа вход подаются два натуральных числа N и M, разделенных пробелом (1 ≤ N, M ≤ 10в4степени). Входные данные таковы, что силы являются целыми числами.Формат выводаНа выходе требуется вывести два числа, разделенные пробелом: сила Тора и сила Локи. Результат будет сравниваться с правильным ответом с точностью 10в -6 степени.Пример 1Ввод Вывод1 22 1Пример 2Ввод Вывод20 525 5

Ответы на вопрос

Ответ: такая же задача уже была сегодня, поэтому дублирую свой ответ еще раз:
program TorLoki;
var
n, m: Integer;
T, L: Double;
begin
Write ('Введите N и M: ');
ReadLn (n, m);
L := n / (m - 1);
T := L + n;
WriteLn ('Сила Тора = ', T :10 :6);
WriteLn ('Сила Локи = ', L :10 :6);
ReadLn;
end.
Объяснение:
нужно решить систему уравнений:
T = L + N
T = L * M
получается
L * M - L = N
L (M - 1) = N
L = N / (M - 1)
это сила Локи, а для Тора:
Т = L + N или T = L * M можно и так и так



Для решения данной задачи можно воспользоваться следующим алгоритмом:
- Считать значения N и M из входных данных.
- Выразить силу Тора через силу Локи с помощью данных условий.
- Вывести полученные значения силы Тора и Локи.
Вот пример реализации данного алгоритма на языке Pascal:
pascalprogram TorAndLoki; var N, M: Integer; ThorPower, LokiPower: Real; begin // Считываем значения N и M ReadLn(N, M); // Вычисляем силу Тора и Локи ThorPower := N * M / (M + 1); LokiPower := ThorPower / M; // Выводим результаты WriteLn(ThorPower:0:6, ' ', LokiPower:0:6); end.
После запуска программы, она считывает значения N и M, вычисляет силу Тора и Локи, а затем выводит результаты с точностью до 6 знаков после запятой.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili