Написать программу на C++ Даны два угла треугольника (в градусах). Определить, существует ли
такой треугольник. Если да, то будет ли он прямоугольным.Ответы на вопрос
Ответ:
#include <iostream>
using namespace std;
int main()
{
setlocale(LC_ALL, "russian");
int a, b, c;
cout << "Введите два угла треугольника в градусах: ";
cin >> a >> b;
c = 180 - b - a;
if (a > 0 && b > 0 && c > 0) {
cout << "\nТреугольник существует.";
if (a == 90 || b == 90 || c == 90)
cout << "\nЭто прямоугольный треугольник.";
}
else
cout << "\nТреугольник не существует.";
}
Для определения существования треугольника по двум заданным углам и проверки, будет ли он прямоугольным, можно воспользоваться следующей программой на C++:
cpp#include <iostream>
int main() {
double angle1, angle2;
std::cout << "Введите первый угол треугольника (в градусах): ";
std::cin >> angle1;
std::cout << "Введите второй угол треугольника (в градусах): ";
std::cin >> angle2;
// Проверка на существование треугольника
double angle3 = 180.0 - angle1 - angle2;
if (angle3 <= 0) {
std::cout << "Треугольник не существует." << std::endl;
} else {
std::cout << "Треугольник существует." << std::endl;
// Проверка на прямоугольность треугольника
if (angle1 == 90 || angle2 == 90 || angle3 == 90) {
std::cout << "Треугольник является прямоугольным." << std::endl;
} else {
std::cout << "Треугольник не является прямоугольным." << std::endl;
}
}
return 0;
}
Программа позволяет пользователю ввести два угла треугольника и затем выполняет проверку существования треугольника (сумма всех трех углов должна быть равна 180 градусов) и на прямоугольность (если хотя бы один угол равен 90 градусам, то треугольник будет прямоугольным).
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
