СРОЧНО! ДАЮ 30 БАЛЛОВ! Составить программу в Паскале, где с клавиатуры вводится число (нечетное),
а на экран выводится квадрат (матрица)Например, Вводится 31 1 11 2 11 1 1Вводится 51 1 1 1 1 1 2 2 2 11 2 3 2 11 2 2 2 1 1 1 1 1 1 и т.д.Ответы на вопрос
Ответ:
program ideone;
uses Math;
var
n, i, j: Integer;
begin
read(n);
for i := 0 to n-1 do
begin
for j := 0 to n-1 do
begin
if (j > 0) then write(' ');
write(Min(Min(i, j), Min(n-i-1, n-j-1))+1);
end;
writeln;
end;
end.
Конечно! Вот пример программы на языке Паскаль, которая реализует указанную логику:
pascalprogram SquareMatrix; var input, i, j, k, num: integer; begin writeln('Введите нечетное число:'); readln(input); // Проверка на нечетность if input mod 2 = 0 then begin writeln('Введено четное число. Попробуйте снова.'); exit; end; num := 1; k := (input div 2) + 1; for i := 1 to input do begin for j := 1 to input do begin if (i = k) and (j = k) then write(num) else write('1 '); num := num + 1; if num > input then num := 1; end; writeln; end; readln; end.
Программа запрашивает у пользователя ввод нечетного числа и затем строит квадратную матрицу, где центральный элемент идентифицируется числом, а остальные элементы заполняются единицами.
Пожалуйста, обратите внимание, что в программе нет проверок на ввод пользователя, поэтому необходимо убедиться, что вводимые данные соответствуют указанным требованиям (нечетное число). Также обратите внимание, что данная программа работает только для чисел больше или равных 1.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
