 
Вопрос задан 16.07.2023 в 08:54.
Предмет Информатика.
Спрашивает Barbq-Junior Андрюха.
1. Составьте программу, увеличивающую введенное число на 1, если оно больше или равно100 и
уменьшающее число на 1 в противном случае. 2. Составить программу, запрашивающую возраст и отвечающую «Привет друг» если возраст введен меньше 16 лет и отвечающую «Не знаю тебя» в противном случае. 3. Составить программу - отзывающуюся только на имя «Петя». ПОЖАЛУЙСТА, помогите 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Тимощук Женя.
                
    ===== PascalABC.NET =====
begin
var n := ReadInteger('Введи целое число:');
if n >= 100 then
n += 1
else
n -= 1;
Write(n)
end.
=========================
begin
if ReadInteger('Сколько тебе лет?') < 16 then
Write('Привет, друг')
else
Write('Не знаю тебя')
end.
=========================
begin
if ReadlnString('Как тебя зовут?') = 'Петя' then
Writeln('Привет,как дела?')
end.
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Конечно! Вот решения для ваших трёх программ на языке Python:
Программа 1: Увеличение или уменьшение числа на 1:
pythonnumber = int(input("Введите число: "))
if number >= 100:
    number += 1
else:
    number -= 1
print("Результат:", number)
Программа 2: Приветствие в зависимости от возраста:
pythonage = int(input("Введите ваш возраст: "))
if age < 16:
    print("Привет, друг!")
else:
    print("Не знаю тебя.")
Программа 3: Отзыв только на имя "Петя":
pythonname = input("Введите ваше имя: ")
if name == "Петя":
    print("Привет, Петя!")
Вы можете запустить каждую программу в среде разработки Python или в интерактивной оболочке, вводя значения в соответствующие поля.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			