 
Пожалуйста помогите "написать программу с использованием подпрограммы для вычисления суммы
s=1+3+5..+a" (ПАСКАЛЬ) 0
        0
         0
        0
    Ответы на вопрос
 
        var a:integer;
function SumN (n:integer):integer;
var
i,sum:integer;
begin
i:=1;
sum:=0;
while i<=n do
begin
sum:=sum+i;
i:=i+2;
end;
if n mod 2 = 0 then sum:=sum+n;
sumN:=sum;
end;
begin
readln(a);
writeln('Сумма нечётных до "a"(вкулючая в сумму "a", даже если оно чётное): ',sumN(a));
end.
 0
                    0
                     0
                    0
                 
            Конечно! Вот пример программы на языке Pascal, которая использует подпрограмму для вычисления суммы ряда чисел:
pascalprogram Summation; function ComputeSum(a: Integer): Integer; var i, sum: Integer; begin sum := 0; for i := 1 to a do begin if i mod 2 <> 0 then sum := sum + i; end; ComputeSum := sum; end; var a, s: Integer; begin Write('Введите значение a: '); ReadLn(a); s := ComputeSum(a); WriteLn('Сумма ряда 1 + 3 + 5 + ... + ', a, ' = ', s); end.
В этом примере программа вводит значение a с клавиатуры. Затем она вызывает функцию ComputeSum, передавая ей значение a, чтобы вычислить сумму ряда. Функция ComputeSum использует цикл для прохода по всем нечетным числам от 1 до a и накапливает их сумму в переменной sum. В результате функция возвращает эту сумму. Наконец, программа выводит полученную сумму на экран.
Вы можете запустить эту программу в среде разработки, поддерживающей язык Pascal, чтобы увидеть результат.
 0
                    0
                     0
                    0
                Похожие вопросы
 
			 
			 
			 
			 
			 
			 
			Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			