Вопрос задан 15.07.2023 в 23:06. Предмет Информатика. Спрашивает Матвиенко Никита.

Напишите программу, в которой выполняется создание типизированного файла, компоненты которого

представляют собой одномерный массив. Преобразовать файл, отрицательные элементы массива отсортировать по убыванию. В среде FreePascal​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Самсонов Максим.

Объяснение:

вроде вот это,ну если нет то прости


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно! Вот пример программы на языке FreePascal, которая создает типизированный файл, содержащий одномерный массив, и сортирует отрицательные элементы по убыванию:

pascal
program TypedFileSorting; const FileName = 'data.bin'; type TArray = array[1..100] of Integer; var DataFile: file of TArray; Data: TArray; i, j, Temp: Integer; begin // Генерируем случайные числа и записываем их в файл Randomize; for i := 1 to 100 do Data[i] := Random(200) - 100; Assign(DataFile, FileName); Rewrite(DataFile); Write(DataFile, Data); Close(DataFile); // Читаем данные из файла Reset(DataFile); Read(DataFile, Data); Close(DataFile); // Сортируем отрицательные элементы массива по убыванию for i := 1 to 100 do begin if Data[i] < 0 then begin for j := i + 1 to 100 do begin if (Data[j] < 0) and (Data[j] > Data[i]) then begin Temp := Data[i]; Data[i] := Data[j]; Data[j] := Temp; end; end; end; end; // Записываем отсортированные данные обратно в файл Rewrite(DataFile); Write(DataFile, Data); Close(DataFile); // Выводим результат Reset(DataFile); Read(DataFile, Data); Close(DataFile); for i := 1 to 100 do WriteLn(Data[i]); ReadLn; end.

Эта программа создает файл data.bin, записывает в него случайно сгенерированные числа от -100 до 100, читает данные из файла, сортирует отрицательные элементы по убыванию и записывает результат обратно в файл. Затем она выводит содержимое файла на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос