Pascal Дан массив из 50 элементов. Каждый элемент может принимать целочисленное значение от -500
до 500. Напишите программу, которая определяет на сколько число положительных элементов массива больше, чем число отрицательных, и выведите найденное значение. Гарантируется, что в исходном массиве есть и отрицательные, и положительные элементы, и положительных элементов больше.Ответы на вопрос
Ответ:
Объяснение:
program ArrayOf50;
const
ArraySize = 50; {Определяем размен массива}
var
x: array[1..ArraySize] of integer;
i, PosCount, NegCount : integer;
begin
PosCount :=0; NegCount :=0; {Устанавливаем счетчики пол. и отр. чисел}
for i:=1 to ArraySize do begin {Цикл ввода данных}
Write('Input ', i, '-th element of array: ');
ReadLn(x[i]);
end;
for i:=1 to ArraySize do begin {Цикл обработки данных}
if x[i] > 0 then PosCount := PosCount+1; {считаем положительные}
if x[i] < 0 then NegCount := NegCount+1; {считаем отрицательные, нули в расчет не берутся!}
end;
Writeln('There are ', PosCount, ' positive numbers.');
Writeln('This is ', PosCount - NegCount, ' more than negatives');
end.
Вот пример программы на языке Pascal, которая решает вашу задачу:
pascalprogram PositiveNegativeDifference; const SIZE = 50; var arr: array[1..SIZE] of integer; positiveCount, negativeCount, difference: integer; i: integer; begin positiveCount := 0; negativeCount := 0; // Заполняем массив случайными значениями for i := 1 to SIZE do begin arr[i] := Random(1000) - 500; // Генерируем случайное число от -500 до 500 if arr[i] > 0 then positiveCount := positiveCount + 1 else negativeCount := negativeCount + 1; end; // Выводим содержимое массива writeln('Массив:'); for i := 1 to SIZE do write(arr[i], ' '); // Вычисляем разницу difference := positiveCount - negativeCount; // Выводим результат writeln; writeln('Число положительных элементов больше, чем число отрицательных, на ', difference); end.
В этой программе мы сначала создаем массив arr из 50 элементов и заполняем его случайными целочисленными значениями от -500 до 500. Затем мы подсчитываем количество положительных и отрицательных элементов в массиве. И, наконец, мы вычисляем разницу между числом положительных и отрицательных элементов и выводим полученное значение.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
