Паскаль. Написать программу нахождения количества элементов массива, значения которых равно 2. Если
таких чисел в массиве нет, то вывести на экран соответствующее сообщениеОтветы на вопрос
Ответ:
Объяснение:
program ArrayOf2;
const
ArraySize=10; {устанавливаем размер массива}
MaxRandom=5; {максимальное случайное число для заполнения массива}
var
x : array[1..ArraySize] of integer;
i, Sum2 : integer;
begin
Sum2:=0;
for i:=1 to ArraySize do x[i]:=Random(MaxRandom); {в цикле заполняем массив случайными числами от 1 до заданной MaxRandom}
for i:=1 to ArraySize do WriteLn(x[i]); {выводим на печать массив, который получился (в задании это не требовалось, можно убрать эту строку)}
for i:=1 to ArraySize do if x[i]=2 then Sum2:=Sum2+1; {считаем двойки}
if
Sum2 > 0
then
Writeln('The quantity of 2 in this array is: ',Sum2)
else
WriteLn('No any 2 in this array was found')
end.
===== PascalABC.NET =====
begin
var n := ReadInteger('Укажи длину массива:');
var a := ArrRandom(n, -5, 5);
var k := a.Println.Count(p -> p = 2);
if k = 0 then
Print('Нет элементов, равных 2')
else
Print('Число элементов, равных 2:', k)
end.

Конечно! Вот пример программы на языке Паскаль, которая находит количество элементов массива со значением 2 и выводит соответствующее сообщение, если таких чисел нет:
pascalprogram CountTwos; var arr: array of Integer; count, i: Integer; begin count := 0; // Заполнение массива значениями SetLength(arr, 5); // Здесь 5 - это размер массива, вы можете изменить его по своему усмотрению arr[0] := 1; arr[1] := 2; arr[2] := 2; arr[3] := 3; arr[4] := 4; // Поиск элементов со значением 2 и подсчет их количества for i := 0 to Length(arr) - 1 do begin if arr[i] = 2 then count := count + 1; end; // Вывод результата или сообщения if count > 0 then writeln('Количество элементов со значением 2: ', count) else writeln('В массиве нет элементов со значением 2.'); readln; end.
Программа создает массив arr и заполняет его значениями. Затем она перебирает все элементы массива и увеличивает счетчик count каждый раз, когда встречается элемент со значением 2. После завершения цикла программа проверяет значение count и выводит соответствующее сообщение.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
