Вопрос задан 14.07.2023 в 17:31.
Предмет Информатика.
Спрашивает Игонин Никита.
на Pascal написать программу, которая из последовательности чисел определит кол-во чисел больше 9 и
кратных 5. последнее число - 0. спасибо заранее!Ответы на вопрос
Отвечает Шварова Виктория.
Ответ:
PascalABC.NET
begin
var N := ReadInteger('Сколько чисел? ');
var A := ReadArrInteger('Вводи: ', N);
A.Where(x -> (x > 9) and (x mod 5 = 0)).Count.Println;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на Pascal, которая позволит определить количество чисел больше 9 и кратных 5 в последовательности чисел, пока не будет введен 0:
pascalprogram CountNumbers; var num, count: integer; begin count := 0; writeln('Введите последовательность чисел, закончив нулем:'); repeat readln(num); if (num > 9) and (num mod 5 = 0) then count := count + 1; until num = 0; writeln('Количество чисел больше 9 и кратных 5: ', count); end.
Программа просит пользователя ввести последовательность чисел, пока не будет введен 0. Затем она проверяет каждое число на условие "больше 9 и кратно 5" и подсчитывает количество чисел, удовлетворяющих этому условию. В конце выводится результат подсчета.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
