Вопрос задан 14.07.2023 в 14:19. Предмет Информатика. Спрашивает Буяльская Анастасия.

Срочно!!!!!! Pascal ABC Net a) составьте программу, выводящую на экран числа от 1 до 10, а также

квадраты и кубы этих чисел в следующем виде:1 1 12 4 8б) Составьте программу, выводящую на экран все числа от - 10 до 10,а также их модули -10 10-9 9​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Матрохин Сергей.

Ответ:

1) Program l1;

Var a:integer;

Begin

For a:= 1 to 10 do Writeln(a, ' ', a*a,' ',a*a*a);

end.

2) Program l2;

Var a,b: integer;

Begin

For a:= -10 to 10 do

begin

b:=Abs(a);

Writeln(a, ' ' ,b);

end;

end.

Я не проверял работает ли , но по идее должно

0 0
Отвечает Покшеватова Яна.

===== PascalABC.NET =====

=1=

begin

 for var a := 1 to 10 do

   Println(a, a * a, a * a * a)

end.

=2=

begin

 for var a := -10 to 10 do

   Println(a, Abs(a))

end.



0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для задачи а) в Pascal ABC Net, вам потребуется использовать цикл for для перебора чисел от 1 до 10 и выводить каждое число, его квадрат и куб на экран.

pascal
program NumbersAndPowers; var num, square, cube: Integer; begin for num := 1 to 10 do begin square := num * num; cube := num * num * num; WriteLn(num, ' ', square, ' ', cube); end; end.

Для задачи б) вам нужно вывести числа от -10 до 10 и их модули. Модуль числа - это его абсолютное значение, то есть без знака.

pascal
program NumbersAndAbsValues; var num: Integer; begin for num := -10 to 10 do begin WriteLn(num, ' ', Abs(num)); end; end.

Обратите внимание, что код в Pascal ABC Net не чувствителен к регистру, поэтому вы можете использовать любой стиль написания команд и ключевых слов (в верхнем или нижнем регистре) для удобства чтения.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос