Вопрос задан 14.07.2023 в 09:17. Предмет Информатика. Спрашивает Шмонько Юлия.

Python Напишите программу, которая будет считывать слово или выражение, затем будет выводить

данное слово N количество раз на N строках. В первой строке вводится слово или выражение. Во второй число N, количество повторения слова или выражения на N строках. Примечание:, чтобы создать перенос текста, используйте символ "\n".
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Теренюк Настя.

Ответ:

s = input()

n = int(input())

for i in range(n):

   print(s)

Объяснение:

0 0
Отвечает Тихонов Денис.

Ответ:

frase = input('введите выражение и кол-во повторов, разделив их символом "::"\nНапример: hello world::5\n').split('::')

[print(frase[0], end = '\n') for i in range(int(frase[1]))]


0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи можно использовать простой скрипт на языке Python. Ниже представлен код, который выполняет указанную задачу:

python
def print_word_n_times(word, n): for _ in range(n): print(word) if __name__ == "__main__": word_or_expression = input("Введите слово или выражение: ") try: N = int(input("Введите количество повторений: ")) print_word_n_times(word_or_expression, N) except ValueError: print("Ошибка: введите целое число для количества повторений.")

Скрипт предоставляет функцию print_word_n_times, которая выводит заданное слово или выражение N раз на отдельных строках. В блоке __name__ == "__main__", мы сначала считываем слово или выражение и количество повторений N с помощью функции input(). Затем вызываем функцию print_word_n_times с введенными значениями.

Пример использования:

Введите слово или выражение: Привет! Введите количество повторений: 5 Привет! Привет! Привет! Привет! Привет!

Обратите внимание, что программа ожидает, что второй ввод будет числом. Если пользователь введет нечисловое значение, возникнет исключение ValueError, и программа выведет сообщение об ошибке.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос