Срочно хелп Надо составить программу которая из ряда чисел выводит числа кратные 3 в паскаль
Ответы на вопрос
Ответ:program chisla;
var i:integer;
begin
for i:=1 to 100 do
begin
if (i mod 3 = 0)
then write(i,' ');
end;
Объяснение:
Ответ:
PascalABC.NET
begin
var (lb, rb) := ReadInteger2('введите начало и конец ряда чисел');
Range(lb, rb).Where(x->x mod 3 = 0).Println;
end.
Или, если ряд - это что то, вводимое с клавиатуры:
begin
ReadSeqInteger('Вводи: ', ReadInteger('Длина последовательности:')).Where(x -> x mod 3 = 0).Println;
end.
Конечно, я могу помочь вам составить программу на языке Паскаль, которая выводит числа из заданного ряда, кратные трём. Вот пример программы:
pascalprogram Кратные_трём; var числа: array[1..10] of integer; // Массив чисел, можно изменить размер в соответствии с вашими требованиями i: integer; begin // Введите числа в массив writeln('Введите ряд чисел:'); for i := 1 to 10 do readln(числа[i]); // Вывод чисел, кратных 3 writeln('Числа, кратные 3:'); for i := 1 to 10 do begin if числа[i] mod 3 = 0 then writeln(числа[i]); end; readln; end.
В этой программе мы используем массив числа, чтобы хранить заданный ряд чисел. Вы можете изменить размер массива, если вам нужно обработать больше или меньше чисел. Затем мы проходим по всем элементам массива и проверяем, делится ли число на 3 без остатка с помощью оператора mod. Если число делится на 3 без остатка, то оно выводится на экран.
Вы можете ввести ряд чисел, например:
Введите ряд чисел: 1 2 3 4 5 6 7 8 9 10
Результатом будет:
yamlЧисла, кратные 3:
3
6
9
Надеюсь, это поможет вам! Если у вас возникнут ещё вопросы, пожалуйста, не стесняйтесь задавать.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
