C++ помогите написать программу!!! Напишите функцию, которая определяет является ли число
простым. В заданном массиве найти сумму всех простых чисел. Заранее спасибоОтветы на вопрос
Ответ:
Объяснение:
#include <bits/stdc++.h>
using namespace std;
bool Prime(int N)
{
for (int i = 2; i <= sqrt(N); i++)
if (N % i == 0)
return false;
return true;
}
int main()
{
int sum = 0;
for (int i = 10; i < 100; i++)
{
if (Prime(i))
sum += i;
}
cout << "Target info:" << "\n";
cout << sum << "\n";
system("pause");
return 0;
}
Конечно, я помогу написать программу на C++, которая определит, является ли число простым, и найдет сумму всех простых чисел в заданном массиве. Вот пример кода:
cpp#include <iostream>
#include <vector>
bool isPrime(int number) {
if (number <= 1)
return false;
for (int i = 2; i * i <= number; ++i) {
if (number % i == 0)
return false;
}
return true;
}
int sumOfPrimes(const std::vector<int>& arr) {
int sum = 0;
for (int num : arr) {
if (isPrime(num))
sum += num;
}
return sum;
}
int main() {
// Пример массива чисел
std::vector<int> numbers = {2, 3, 5, 7, 10, 11, 13};
int sum = sumOfPrimes(numbers);
std::cout << "Сумма всех простых чисел в массиве: " << sum << std::endl;
return 0;
}
Обратите внимание, что функция isPrime() проверяет, является ли число простым, путем проверки деления на все числа от 2 до корня из этого числа. Если оно делится на любое из этих чисел без остатка, то оно не является простым. В примере main() мы использовали массив numbers для демонстрации работы функции sumOfPrimes(). Вы можете изменить значения в массиве или использовать свой собственный массив чисел для тестирования программы.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
