Вопрос задан 13.07.2023 в 23:11. Предмет Информатика. Спрашивает Мирошниченко Лера.

Составить программу перевода градусов Цельсия в Градусы Фаренгейта от a до b ,a>b, вывод

организовать в столбцы язык паскаль
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Чернова Александра.

Ответ:

### PascalABC.NET ###

function Tofahrenheit(cels_deg:integer):= cels_deg * 1.8 + 32;

begin

 var (a, b) := ReadInteger2('a, b: ');

 Range(a, b).Tabulate(x -> Tofahrenheit(x)).Println;

end.

Объяснение:

0 0
Отвечает Марчук Ульна.

Ответ:

Var

n:integer;

Begin

Writeln('Введите в градусах Цельсия)

Read(n)

Writeln('В Франгейтай это = ',

(n*9/5)+32:0:1);

end

ещё совет лучше перепиши вручную, не копируй!

так как тут другой шрифт

и ещё можно так;

f:=(n*9/5)+32 а потом Writeln(f:0:1);

end

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Ниже представлена программа на языке Паскаль, которая выполняет перевод градусов Цельсия в градусы Фаренгейта в заданном диапазоне от a до b (где a > b). Результаты выводятся в столбцы.

pascal
program CelsiusToFahrenheit; var a, b, celsius: Integer; fahrenheit: Real; begin WriteLn('Градусы Цельсия Градусы Фаренгейта'); WriteLn('----------------------------------'); // Ввод диапазона от a до b Write('Введите начальное значение (a): '); ReadLn(a); Write('Введите конечное значение (b): '); ReadLn(b); // Перевод и вывод результатов for celsius := a downto b do begin fahrenheit := celsius * 9/5 + 32; WriteLn(celsius, ' ', fahrenheit:0:2); end; end.

Программа принимает ввод от пользователя для начального значения a и конечного значения b. Затем она выполняет цикл для каждого градуса Цельсия в диапазоне от a до b (включая a и b). Каждый градус Цельсия переводится в градусы Фаренгейта и выводится в столбцы с помощью команды WriteLn.

Пожалуйста, обратите внимание, что программа требует компилятора Паскаля для выполнения.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос