Вопрос задан 13.07.2023 в 21:52.
Предмет Информатика.
Спрашивает Хомик Вадим.
Помогите пожалуйста написать программу здоровья для 15-30 летнего человека на языке
Паскаль(информатика 8 класс). СпасибоОтветы на вопрос
Отвечает Черняк Влад.
Если помогла чем то то только так

Отвечает Игликов Абдувахит.
Могу только так помочь.
program Zadachka;
var
a:integer;
begin
writeln('Введите возвраст');
readln(a);
case a of
0..5: writeln('Дошкольник');
6..18: writeln ('Ученик');
19..59: writeln('Работник');
60..120:writeln ('Пенсионер');
else writeln('Вы ввели неверные данные');
end;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь вам написать программу для оценки здоровья 15-30-летнего человека на языке Паскаль. В этой программе мы попросим пользователя ввести информацию о своем здоровье и выведем общую оценку. Пожалуйста, вот пример программы:
pascalprogram HealthAssessment; var age: integer; height, weight: real; bmi: real; pulseRate: integer; isSmoker, isDrinker: boolean; healthRating: string; begin writeln('Добро пожаловать в программу оценки здоровья!'); // Ввод информации writeln('Пожалуйста, введите ваш возраст (от 15 до 30): '); readln(age); writeln('Введите ваш рост в метрах: '); readln(height); writeln('Введите ваш вес в килограммах: '); readln(weight); writeln('Введите ваш пульс в ударах в минуту: '); readln(pulseRate); writeln('Вы курите? (Введите "1" - да, "0" - нет): '); readln(isSmoker); writeln('Вы употребляете алкоголь? (Введите "1" - да, "0" - нет): '); readln(isDrinker); // Рассчет индекса массы тела (BMI) bmi := weight / (height * height); // Оценка здоровья if (age >= 15) and (age <= 30) then begin if (bmi >= 18.5) and (bmi <= 24.9) and (pulseRate >= 60) and (pulseRate <= 100) and (not isSmoker) and (not isDrinker) then healthRating := 'Отличное' else if (bmi >= 17) and (bmi <= 29.9) and (pulseRate >= 50) and (pulseRate <= 120) then healthRating := 'Хорошее' else healthRating := 'Плохое'; end else healthRating := 'Некорректный возраст'; // Вывод результата writeln; writeln('Результат оценки здоровья:'); writeln('---------------------------'); writeln('Индекс массы тела (BMI): ', bmi:0:2); writeln('Пульс: ', pulseRate); writeln('Курение: ', isSmoker); writeln('Употребление алкоголя: ', isDrinker); writeln('Оценка здоровья: ', healthRating); writeln('---------------------------'); end.
Примечание:
- Программа предполагает, что пользователь будет вводить данные корректно.
- В этом примере оценка здоровья основана на условиях ИМТ (индекс массы тела), пульсовой частоты, курении и употреблении алкоголя. В реальных условиях медицинские оценки могут быть более сложными и включать больше параметров.
- Пользователь должен вводить 1 для ответа "да" на вопросы о курении и употреблении алкоголя, и 0 для ответа "нет".
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 22
Информатика 36
Информатика 60
Информатика 2166
Информатика 10
Информатика 571
Информатика 49
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
